皇上,还记得我吗?我就是1999年那个Linux伊甸园啊-----24小时滚动更新开源资讯,全年无休!

ThinkPHP 5.1.18 版本发布,完善 Swoole/Workerman 支持

ThinkPHP

V5.1.18 版本主要完善了对`Swoole`和`Workerman`的`HttpServer`运行支持,改进`Request`类,并修正了一些已知的问题。

[ 主要更新 ]

  • 改进关联`append`方法的处理
  • 路由初始化和检测方法分离
  • 修正`destroy`方法强制删除
  • `app_init`钩子位置移入`run`方法
  • `think-swoole`扩展更新到 2.0 版本
  • `think-worker`扩展更新到 2.0 版本
  • 改进 Url 生成的域名自动识别
  • `Request`类增加`setPathinfo`方法和`setHost`方法
  • `Request`类增加`withGet`/`withPost`/`withHeader`/`withServer`/`withCookie`/`withEnv`方法进行赋值操作
  • Route 类改进`host`属性的获取
  • 解决注解路由配置不生效的问题
  • 取消 Test 日志驱动,改为使用`close`设置关闭全局日志写入
  • 修正路由的`response`参数
  • 修正 204 响应输出的判断

从`5.1.17`版本可以无缝升级到`5.1.18`。由于取消了 Test 日志驱动,如果使用了 Test 日志驱动,请在 log.php 中改为使用下面的配置全局关闭。

'close'  => true,

[ Swoole/Workerman 支持 ]

该版本开始,可以更好的支持 Swoole 和 Workerman 的 HTTPServer 运行。

在你的项目根目录下面,安装或者更新 think-swoole(或者 think-worker)扩展

composer require topthink/think-swoole

// 或者

composer require topthink/think-worker

然后启动 HttpServer 服务

php think swoole
// 或者
php think worker

注意:swoole 不支持 windows 服务器

官方 完全开发手册 已经同步更新!

转自 https://www.oschina.net/news/97629/thinkphp-5-1-18-released

分享到:更多 ()