皇上,还记得我吗?我就是1999年那个Linux伊甸园啊-----24小时滚动更新开源资讯,全年无休!

Hibernate Validator 6.0.12.Final 改进 JDK 11 支持

Hibernate Validator 6.0.12.Final 已发布,建议 6.x 版本的用户尽快升级,它是 6.0.11.Final 的直接替换版本,改进和修复了与 JDK 11 的兼容性并调整了 CDI 集成。

What’s new

CDI 集成

在使用 Hibernate Validator 6.0.10.Final 时,如果类自身没有 Bean Validation 注释,那么在使用 CDI 集成时,类的方法将无法验证。

由于 CDI 不允许在父类和接口的注释上过滤类,这导致开发团队只能暂时通过扫描 CDI 传递过来的类的整个类层次结构中的注释来解决问题。这并不是理想的解决方式,后续将持续改进。

JDK 11 支持

当与 JDK 11 一起使用时,Hibernate Validator 会将 JavaFX 作为依赖项,现已得到修复。

此外,还改进了一些额外的基础设施工作,以便能够运行 WildFly 集成测试,并在带有 JDK 11 的 WildFly container 中运行 TCK 测试套件。

更多细节可查阅:

下载地址:TAR.GZ 、ZIP

转自 https://www.oschina.net/news/98960/hibernate-validator-6012-released

分享到:更多 ()