皇上,还记得我吗?我就是1999年那个Linux伊甸园啊-----24小时滚动更新开源资讯,全年无休!

Chrome Manifest V3变化将会影响 TamperMonkey 扩展。


在 Google Groups 的帖子中,TamperMonkey 扩展的作者表示,如果 Chrome Manifest V3 版本实施 ,TamperMonkey 将会受到很严重的影响。

Chrome 扩展具有哪些功能和权限由 Chrome Manifest V2 管理。即将发布的 V3 版本对扩展执行的权限做了新的限制,如果该限制生效,那么一些扩展将不再有用,如 uBlock 广告拦截扩展。

V3 版本还建议阻止扩展使用远程托管的脚本。这样做是为了增强安全性,保护用户免受恶意软件的攻击,恶意软件通常会导入外部脚本。这样做还可以让谷歌更好的审核扩展程序。

在Chromium Extensions 小组的一篇文章中,TamperMonkey 开发人员 Jani Biniok 表示,这一改动将影响他的扩展不能正常工作,因为加载远程脚本是插件核心功能的一部分。

TamperMonkey 是一个用户脚本管理器,允许用户创建可由扩展远程加载的 Java Script脚本,方便用户优化他们经常访问站点。TamperMonkey 拥有超过 400000 个脚本和超过 1000 万个用户,是一个非常受欢迎的扩展。由于 Google 认识到使用远程托管脚本可能会被滥用,Jani Biniok 请求获得新的权限,以避免对该扩展的影响,希望对具有此权限的扩展受到进行更严格的审核,并在安装该扩展时向用户发出警告。

TamperMonkey官网:https://tampermonkey.net/

转自 https://www.oschina.net/news/104038/tampermonkey-may-be-next-victim-of-googles-chrome-manifest-v3

分享到:更多 ()