皇上,还记得我吗?我就是1999年那个Linux伊甸园啊-----24小时滚动更新开源资讯,全年无休!

TensorFlow 1.14.0 发布,引入 compat.v2 模块

TensorFlow 1.14.0 发布了,此版本包含不少新特性和功能改进,还修复了大量的 bug。

主要新特性和功能改进:

  • 这是包含 compat.v2 模块的第一个 1.x 版本。该模块要求 Tensorflow 库发布在 1.x 和 2.x 中都有效的代码。在此版本之后,2.0 Python API 中不允许进行向后不兼容的更改。
  • 默认情况下打开 MKL-DNN contraction 内核。MKL-DNN 基于 CPU 矢量体系结构动态调度最佳内核实现。要禁用它们,请使用  –define=tensorflow_mkldnn_contraction_kernel=0 进行构建。
  • 现在,非 Windows 系统库已经过版本控制,它只影响系统包维护者或那些构建 TensorFlow 的扩展:
    • Python wheels(Pip 包)包含一个库文件
      • Linux:libtensorflow_framework.so.1
      • MacOS: libtensorflow_framework.1.dylib
    • libtensorflow 存档包含 libtensorflow 库和两个符号链接。 MacOS .dylib 库是一样的, 但符合 MacOS 库命名要求(即 libtensorflow.1.dylib):
      • libtensorflow.so.1.14.0,主要的库
      • libtensorflow.so.1,符号链接到主库
      • libtensorflow.so,符号链接到 .so.1

新版本还包含大量更改和 bug 修复,详情请查看更新说明

转自 https://www.oschina.net/news/107581/tensorflow-1-14-0-released

分享到:更多 ()