皇上,还记得我吗?我就是1999年那个Linux伊甸园啊-----24小时滚动更新开源资讯,全年无休!

Linux Systemd 又被曝高危远程溢出漏洞

近日,开发者 Chris Coulson 发现,在许多 Linux 版本中的 systemd 初始化系统有一个高危远程溢出漏洞(漏洞编号为 CVE-2017-9445),攻击者可以通过返回包含有特制 TCP 攻击负载的响应就能触发该漏洞,进而导致可在 Linux 系统上执行任意代码。

systemd 是 Linux 下的 init 软件,主要用于减少系统引导时间和计算开销。而从 2015 年 6 月的 Systemd 223 到今年 3 月份 Systemd 233 之间的所有版本都受到上述漏洞影响。

据悉,出问题的是 systemd-resolved 域名解析服务。该开发者表示,恶意的 DNS 服务器可利用特制的 TCP 攻击负载让 systemd-resolved 分配过小的缓冲区,从而触发该溢出漏洞,此后则能在系统中执行任意程序了。

目前针对该漏洞,Ubuntu 已经推出了相应的修复补丁,Debian 则表示虽然使用了含有漏洞的 systemd 版本,但当中 systemd-resolved 服务的预设值是关闭的,而红帽的 Red Hat Enterprise Linux 7 则采用了 systemd 219,因此不受影响。

来自:中关村在线 作者:郑伟

分享到:更多 ()