皇上,还记得我吗?我就是1999年那个Linux伊甸园啊-----24小时滚动更新开源资讯,全年无休!

Apache Ant 1.9.13 和 1.10.5 发布,自动化构建工具

Apache Ant

Apache Ant 1.9.13 和 1.10.5 已发布,下载地址为 https://ant.apache.org/bindownload.cgi

Apache Ant 目前维护着两个分支,1.9.x 系列要求 Java 5 以上,而 1.10.x 要求 Java 8 以上。1.9.x 系列主要是修复 bug,1.10.x 会增加新功能,官方推荐使用 1.10.x,除非在构建过程中需要使用 Java 8 之前的 Java 版本。

Ant 1.10.5 包含 1.9.13 的超集,除了一些不再适用于 Java 8 的任务和功能(如 apt 任务),这两个版本都修复了 get 任务中的错误回归,以及分别在 1.9.12 和 1.10.4 中引入的 unarchiving 任务的路径遍历保护中的错误。

Ant 1.10.5 的 java 任务增加了对 Java 11 引入的单文件源执行功能的支持。

转自 https://www.oschina.net/news/98121/apache-ant-1-9-13-and-1-10-5-released

分享到:更多 ()